NET-Framework bedingt abwärtskompatibel

Mehr
6 Jahre 3 Monate her - 6 Jahre 3 Monate her #1235 von toja
Ist das .NET-Framework etwa nicht abwärtskompatibel?

Grundsätzlich ist im .NET-Framework 4 auch alles enthalten, was die Vorversionen, genauer: die ab Version 2.0, mitbringen. Es sollte also eigentlich reichen, die aktuelle Version zu installieren, um Software zum Laufen zu bringen, die ein älteres Framework erwartet.
Allerdings gibt es Software, die nicht auf „mindestens Version 3.0“, sondern auf „genau Version 3.0“ prüft und den Start verweigert, wenn sie eine andere Ausgabe vorfindet. Für solche Fälle hält Microsoft das ".NET Framework Family Update" zum Download bereit. Bei der Installation ist es wichtig, die drei Pakete in der angegebenen Reihenfolge von der ältesten zur neuesten Version einzuspielen.

*

Bitte Anmelden oder Registrieren um der Konversation beizutreten.